Repository navigation
chore(deps): bump vulnerable dependencies - #258
Merged
Merged
Conversation
Group the security updates so pip-audit passes in CI: - certifi 2026.7.22 -> 2026.10.23 (GHSA-6q48-6c7w-9gw2, compromised emSign CAs) - pillow 12.3.0 -> 13.0.0 (heap overflows in FPX/JPEG decoding, stale storage reuse, DoS) - djangorestframework 3.18.1 -> 3.18.3 (GHSA-33wh-fxxf-88vv, GHSA-3547-9m27-7rxg, GHSA-xw6w-gcfp-cf8m) - filelock 4.0.3 -> 4.2.6 (local lock-file races and symlink attacks) - msgpack 1.2.2 -> 1.2.4 (GHSA-j586-36cw-2gc2, memory leak) - uv 0.12.19 -> 0.13.6 (GHSA-hq85-5cpj-mr62, compromised CA) Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This was referenced Oct 31, 2026
3 of 5 tasks
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
Groups the Dependabot security updates into a single PR. Each Dependabot PR bumped only one package, so
pip-auditin CI kept failing on the vulnerabilities fixed by the others: the PRs blocked each other.Pillow 13 is a major bump, but Pillow is only a transitive dependency (Wagtail / Willow); the project never imports
PILdirectly.Forcing uv >= 0.13.6
Every uv pin is bumped to 0.13.6 (
mise.toml,Dockerfile, uv-pre-commit hook rev, dev dependency lower bound), and[tool.uv] required-version = ">=0.13.6"makes older uv binaries refuse to run on the project, both in CI (setup-uvreads it) and locally. Developers must upgrade uv (mise install,uv self updateorbrew upgrade uv).Supersedes #253, #254, #255, #256, #257.
Test plan
uv run pip-audit: no known vulnerabilitiesmanage.py test pythonie --settings=pythonie.settings.tests: OK🤖 Generated with Claude Code