Repository navigation
chore(dev): require uv >= 0.13.6 - #259
Merged
Merged
Conversation
uv < 0.13.4 bundles a root CA whose intermediate has been compromised (GHSA-hq85-5cpj-mr62). Bump every uv pin to 0.13.6 (mise, Dockerfile, uv-pre-commit hook, dev dependency lower bound) and set [tool.uv] required-version so older uv binaries refuse to run on the project, in CI (setup-uv reads it) and on developer machines. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
Follow-up to #258: this commit was pushed after #258 had already been merged, so it never reached
master.uv < 0.13.4 bundles a root CA whose intermediate has been compromised (GHSA-hq85-5cpj-mr62). #258 bumped uv in
uv.lockonly; this PR forces it everywhere:pyproject.toml: dev dependency lower bounduv>=0.13.6, plus[tool.uv] required-version = ">=0.13.6"so older uv binaries refuse to run on the project (CI viasetup-uv, and locally)mise.toml: uv 0.13.6Dockerfile:ghcr.io/astral-sh/uv:0.13.6.pre-commit-config.yaml: uv-pre-commitrev: 0.13.6Developers must upgrade uv after this is merged (
mise install,uv self updateorbrew upgrade uv); uv 0.12.x now fails with "Required uv version>=0.13.6does not match the running version".Test plan
uv lock --checkwith uv 0.13.6required-versionpip-auditand the test suite pass locallytask docker:buildstill builds🤖 Generated with Claude Code