Repository navigation
[CRITICAL] fix: CVE-2026-96889 — bump next - #155
Open
Pattern Security Automation (pattern-security-automation) wants to merge 1 commit into
Open
Pattern Security Automation (pattern-security-automation) wants to merge 1 commit into
Pattern Security Automation (pattern-security-automation) wants to merge 1 commit into
Conversation
CVE: CVE-2026-96889 Component: next Fixed version: 16.4.1 Manifest: web/package.json Dependency type: direct
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Supply Chain Vulnerability — Auto-Remediation PR
CVE Details
CVE-2026-96889patterninc/heimdallnext16.4.116.3.8What Changed
next:
16.3.8→16.4.1web/package.jsonweb/pnpm-lock.yamlLock File Status
Lock file updated
CI Validation
False positive?
AI Triage Analysis
Verdict: True Positive
Reasoning: The
nextpackage version 16.3.8 is listed as a direct dependency inweb/package.jsonand is actively used throughout the codebase. Multiple source files import fromnext/dynamic,next/link, andnext/navigation, confirming the Next.js framework is central to the web application. The installed version 16.3.8 falls within the vulnerable range (>= 16.0.0, < 16.4.1) per the advisory. Note that the CVE description mentions librsvg/XML processing which seems mismatched with a Next.js advisory, but the Wiz description explicitly references GHSA-2464-fhr4-w9xw for Next.js at this version, so the finding appears legitimate as a Next.js vulnerability regardless of the description mismatch.References
Developer feedback
Was this automation helpful? Share feedback (takes ~1 min)
Auto-generated by Pattern Security Automation