Problem
My environment periodically updates the AWS temporary credentials in the .aws directory.
DBHub uses fromIni() to load the credentials for RDS IAM authentication. However, fromIni() may continue using cached credentials after the credentials file has been updated.
As a result, DBHub eventually uses expired credentials and RDS IAM authentication fails with:
PAM authentication failed for user "xxx"
Currently, I have to restart the DBHub container to make it pick up the latest credentials.
Expected behavior
DBHub should use the latest AWS credentials from the .aws credentials file when refreshing the RDS IAM authentication token.
Environment
- DBHub: 1.2.5
- Database: Amazon RDS PostgreSQL
- Authentication: AWS IAM
- AWS credentials: temporary STS credentials
- I update the credentials under the .aws directory externally.
Related PR
#436
Problem
My environment periodically updates the AWS temporary credentials in the .aws directory.
DBHub uses fromIni() to load the credentials for RDS IAM authentication. However, fromIni() may continue using cached credentials after the credentials file has been updated.
As a result, DBHub eventually uses expired credentials and RDS IAM authentication fails with:
PAM authentication failed for user "xxx"
Currently, I have to restart the DBHub container to make it pick up the latest credentials.
Expected behavior
DBHub should use the latest AWS credentials from the .aws credentials file when refreshing the RDS IAM authentication token.
Environment
Related PR
#436