Skip to content

Feature: suggest making IMDSv2 a default #1908

Description

@omni1504

What would you like to be added?

In certain environments where IMDSv1 is disabled (e.g. setting enforced via preventive policies), self-provisioning a workshop will fail:

{"level":"error","ts":"2026-08-19T08:32:30Z","logger":"setup","msg":"unable to initialize AWS cloud","error":"failed to introspect vpcID from EC2Metadata or Node name, specify --aws-vpc-id instead if EC2Metadata is unavailable: failed to fetch VPC ID from instance metadata: EC2MetadataError: failed to make EC2Metadata request\n\n\tstatus code: 401, request id: "}

  • alternative error is a timeout issue due a single-hop.

Why is this needed?

Suggest to adapt a managed node group config to use IMDSv2 by default. e.g:

module "eks" {
  source = "terraform-aws-modules/eks/aws"
  # ...
  eks_managed_node_groups = {
    default = {
      # ... existing config ...
      metadata_options = {
        http_endpoint               = "enabled"
        http_tokens                 = "required"
        http_put_response_hop_limit = 2      
      }
    }
  }
} 

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    enhancementNew feature or request

    Type

    No type

    Projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions