Skip to content

[appserver-io-dist/debian] Post-install fails for upgrade if one service is not running #1068

Description

@wick-ed

If an appserver upgrade takes place the postinstall script checks for the status of the appserver processes and restarts them if needed.
If one of the processes is indeed NOT running (was observed with appserver-php5-fpm), the postinstall script will fail with status 3.

See the line of postinstall:
https://github.com/appserver-io-dist/debian/blob/master/src/8/dist/DEBIAN/postinst#L59

Assumption:
The exit code of the systemctl status command gets returned for the whole postinstall script

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions